Issue with “Show History” for Reviews

Incident Report for AppFollow Status Page

Resolved

We are currently investigating an issue where the “Show History” option for reviews is not loading and displays a “Something went wrong” error. Our team is working to identify the cause and restore normal functionality.
Posted Aug 26, 2025 - 18:43 UTC