Issue with the site, pages may not load
Incident Report for AppFollow Status Page
Resolved
This incident has been resolved. Thank you for your patience!
Posted May 10, 2021 - 16:24 UTC
Identified
We are currently experiencing a service outage. Some pages may not load properly, team is working on the fix, the root cause is identified. We'll keep you updated on the status.
Posted May 10, 2021 - 13:31 UTC
This incident affected: Watch.