Reviews' feed loading issue
Incident Report for AppFollow Status Page
Resolved
The issue is resolved.
Posted Nov 10, 2021 - 11:48 UTC
Identified
There is an issue with reviews' feed and reply to reviews page loading. Fix is on its way.
Posted Nov 10, 2021 - 11:24 UTC
This incident affected: Watch.