Issue with AppFollow website
Incident Report for AppFollow Status Page
Resolved
Everything should be back to normal now.
Posted May 31, 2021 - 14:21 UTC
Update
We are continuing to investigate this issue.
Posted May 31, 2021 - 14:21 UTC
Investigating
We are currently experiencing some issues with page loading. The issue is being investigated.
Posted May 31, 2021 - 10:36 UTC
This incident affected: Watch.