Scheduling enabled, reviews transfer alert delivery completely restored.
Posted Mar 04, 2026 - 10:20 UTC
Monitoring
The incident affected alerts for apps with auto-translation enabled only. The root cause was a mismatch between how checksums were calculated and stored for duplicate detection, which caused some alerts to be sent multiple times. This edge case was not covered in pre-release testing. The issue has been identified and addressed.
Missed reviews for today have been successfully triggered for the period during which alerts were paused. Scheduling is planned to be enabled soon.
Posted Mar 04, 2026 - 08:17 UTC
Investigating
Following the latest maintenance related to alerts, we’ve observed duplicate review transfer alerts being sent to Slack channels in some cases. At the moment, we haven’t identified the exact root cause yet, but we are actively investigating the issue.
Important: As a precaution, we have temporarily disabled all review transfer alerts for tonight.