AppFollow Outage

Incident Report for AppFollow Status Page

Monitoring

A fix has been implemented and we're monitoring results.
Posted Mar 23, 2026 - 14:40 UTC

Investigating

We are currently facing an outage where some features of our platform are currently unresponsive. We are investigating the issue and will keep users updated.
Posted Mar 23, 2026 - 12:04 UTC
This incident affects: Watch.