Issue with AppFollow pages' loading

Incident Report for AppFollow Status Page

Resolved

The incident is now resolved.
Posted Dec 23, 2021 - 15:36 UTC

Investigating

We have downgraded performance and we’re investigating the issue now.
We apologise for the inconvenience.
Posted Dec 23, 2021 - 10:49 UTC
This incident affected: Watch.