Issues with infrustructure
Incident Report for AppFollow Status Page
Resolved
Everything is back to normal.
Posted Jul 13, 2021 - 17:20 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jul 13, 2021 - 17:20 UTC
Identified
Amazon has reported an issue which affect our infrastructure. They say the fix is on its way. Currently AppFollow website can be affected - not load or do it slowly. Sorry for the inconvenience!
Posted Jul 13, 2021 - 14:29 UTC
This incident affected: Watch.