Global Outage

Incident Report for AppFollow Status Page

Resolved

Our engineers have identified and fixed the issue on our end! Everything should be back to normal and fully functional.
Posted Jun 09, 2026 - 16:27 UTC

Investigating

We are currently experiencing a global outage, and AppFollow may be unavailable to all users. Our engineering teams are working on this hands-on with top priority to restore functionality as soon as possible.
Posted Jun 09, 2026 - 16:24 UTC
This incident affected: Watch.