Issue with ASO pages
Incident Report for AppFollow Status Page
Resolved
It's back to normal now, network failure in our cloud provider took place.
Posted Nov 05, 2020 - 14:02 UTC
Update
We are continuing to work on a fix for this issue.

ETA: 1 hour.
Posted Nov 05, 2020 - 13:36 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 05, 2020 - 13:32 UTC
Identified
We are facing some issues with ASO services and pages. We are working on the fix already. Solution is expected within an hour.
Posted Nov 05, 2020 - 13:31 UTC
This incident affected: Watch, App Store (ASO), and Google Play (ASO).