New App Store Connect integrations unavailable
Incident Report for AppFollow Status Page
Resolved
This incident has been resolved, and the platform is working normally.

Thank you for your patience and cooperation.
Posted Apr 18, 2023 - 11:53 UTC
Identified
New integrations with App Store Connect are currently unavailable as a result of an issue on the App Store's side with sending invitations. We apologize for any inconvenience caused. Unfortunately, we do not have an estimated time for resolution as we await for Apple to address the issue on their end.
Posted Apr 17, 2023 - 12:51 UTC
This incident affected: Watch, API and App Store (Data Source Connection).