Issue with Apple Invite Source Connects

Incident Report for AppFollow Status Page

Identified

Sending replies may be delayed, accepting invite accounts may fail, and data in ASO App Store Channel analytics may be missing.
Posted Sep 11, 2026 - 07:42 UTC
This incident affects: App Store (Data Source Connection).