AppStore Connect integration downtime
Incident Report for AppFollow Status Page
Resolved
This incident has been resolved, and the platform is working normally.

Thank you for your patience and cooperation.
Posted Apr 17, 2023 - 12:49 UTC
Update
The issue with our App Store Connect integrations is resolved completely.
Our engineering team is still working on the fix for the ASC 2FA Beta integrations, they are unavailable for some clients.
The next update on the issue is expected this Friday, thank you for your understanding.
Posted Mar 22, 2023 - 13:50 UTC
Monitoring
The issue with App Store Connect integrations that caused disruptions and errors for some users seems to be resolved. Our team is still monitoring the situation for any residual issues or delays.
Thank you for your patience and understanding.
Posted Mar 16, 2023 - 11:40 UTC
Investigating
Some AppStore Connect Integrations are temporarily unavailable. We are investigating the issue on our end.
Posted Mar 15, 2023 - 15:32 UTC
This incident affected: Watch, API and App Store (Data Source Connection).