Partial service outage for clients from global2 server

Incident Report for AppFollow Status Page

Resolved

Reviews feed, Templates and probably some other features were not available.
Issue was resolved the next day.
Posted Feb 13, 2026 - 22:00 UTC