Issues with Data Collection and Display - Channel Analytics page

Incident Report for AppFollow Status Page

Identified

Android data collection has been successfully restored. The issue with iOS data is still ongoing and has been traced to a 3rd-party service. We’re in contact with them and will provide updates as we learn more.
Posted Apr 14, 2025 - 13:55 UTC

Investigating

Data collection and display for both Android and iOS apps has ben facing issues, starting around March 23rd until now. Our team is already aware of the issue, and investigating the root cause.
Posted Mar 31, 2025 - 17:26 UTC
This incident affects: App Store (ASO) and Google Play (ASO).