Reviews Dashboard page is not operational.
Incident Report for AppFollow Status Page
Resolved
This issue has been resolved. Reviews Dashboard is fully operational now.
Posted Oct 26, 2020 - 11:04 UTC
Update
We are continuing to investigate this issue.
Posted Oct 26, 2020 - 06:46 UTC
Investigating
We are currently investigating the issue.
Posted Oct 26, 2020 - 06:45 UTC
This incident affected: Watch.