Issue with creating App Store Source Connections

Incident Report for AppFollow Status Page

Resolved

This incident has been resolved.
Posted May 19, 2026 - 14:27 UTC

Monitoring

We experienced issues with creating App Store Source connections over the past week, approximately since May 11th. If you notice any of your App Store connections stuck in a "Pending" state, please remove the connection and set it up again.
Posted May 19, 2026 - 14:26 UTC