App Store ASO Keyword Collection and Scoring Delay

Incident Report for AppFollow Status Page

Resolved

This incident has been resolved.
Posted Aug 12, 2025 - 12:05 UTC

Identified

We're currently experiencing delays in collecting ASO keyword data and calculating scores for App Store apps. Some scores may stay in a “Calculating” state longer than usual. The issue is being investigated.
Posted Aug 01, 2025 - 09:31 UTC