A temporary fix has been deployed and services are operating. We are continuing work on a long-term solution.
Posted Apr 23, 2026 - 15:33 UTC
Investigating
We are currently experiencing a global issue with Trustpilot data collection. Search, ratings, and reviews are temporarily unavailable. Our team is investigating.
Posted Apr 22, 2026 - 08:46 UTC
This incident affects: Trustpilot (Ratings, Reply to Reviews).