Issues with internal instruments increased Customer Support response time
Incident Report for AppFollow Status Page
Resolved
All issues with sign-in processes and internal instruments were resolved.
Posted Mar 08, 2022 - 16:09 UTC
Update
Some customers may experience trouble signing in.
Posted Mar 08, 2022 - 06:41 UTC
Identified
We are currently experiencing a problem with internal instruments which affects response time of Customer Support team. We are already working on the fix. More updates to follow.
Posted Mar 08, 2022 - 06:38 UTC
This incident affected: Watch.