AppStore invites acceptance issue

Incident Report for AppFollow Status Page

Resolved

The issue was resolved on AppStore's side, invitation accepting and source connection setting are back to normal.
Posted Mar 23, 2026 - 12:07 UTC

Investigating

We're unable to accept any invitations, either automatically or manually. It seems there is a problem on Apple side.
Posted Mar 19, 2026 - 13:50 UTC
This incident affected: App Store (Data Source Connection).