App version data temporary unavailable

Incident Report for AppFollow Status Page

Resolved

The incident has been resolved and all the App data is available.
Posted Apr 28, 2022 - 07:17 UTC

Identified

We have spotted and identified the issue with App version data. Some information about apps could be unavailable. We have applied the fix and will update the status as soon as everything is back to normal.
Posted Apr 27, 2022 - 13:16 UTC
This incident affected: Watch.