Delays in reviews collection.
Incident Report for AppFollow Status Page
Resolved
The issue has been resolved.
Reviews collected as expected.
Posted Oct 07, 2022 - 08:12 UTC
Update
Hello! We hope your week has started well.

We have almost restored full functionality for all paid customers. Our free customers, however, can see a lack or even no Google Play reviews at all in their accounts. This is temporary, and soon everything will be back and functioning as it was.

Thank you and keep checking updates.
Posted Aug 08, 2022 - 10:39 UTC
Monitoring
Hello! Review collection and reviews related functionality is fully recovered for paid customers on our main servers, including:

- Google Play reviews collection
- Sending Google Play reviews to tickets in helpdesk system (we had a small bug for a few hours when wrong reviews to customers, it was quickly detected and fixed within a few hours)
- Google Play reviews translation
- Processing semantic data for new reviews

For App Store reviews, all these functionalities are already available for all.

Next steps:
- Monitoring the stability on those servers where the fix was applied
- Continue applying the fix for the rest of the customers

Thank you and stay tuned!
Posted Aug 05, 2022 - 05:11 UTC
Update
Hi there! We have a small status update—the issue is gone for App Store reviews, they are being collected on time. There are still some delays in Google Play reviews collection. We are working hard to resolve it as soon as possible.
Posted Aug 03, 2022 - 12:10 UTC
Identified
The issue has been identified, and the fix is being implemented. We are very grateful for your patience!
Posted Aug 02, 2022 - 13:18 UTC
Update
Hi there! We are still experiencing this unpleasant issue with a delay in reviews collection. Right now, we focus on overall performance and processing parsing data across all servers. Bringing back the stability of the service is our main priority.

We found one hypothesis regarding the delay. It is connected to us changing the processes and moving from legacy publishing tasks for stores to a new platform. That resulted in generating too many tasks for publishing and caused an overload for our cluster of processing data.

We will carry on with the investigation, meanwhile preparing the fix.
Posted Aug 01, 2022 - 13:10 UTC
Investigating
Hello! We are currently experiencing some delays in collecting reviews from both App Store and Google Play. At the moment we are looking into the cause and will update you very soon.
Posted Jul 29, 2022 - 09:24 UTC
This incident affected: Watch.