Changes to the Google Play Developer Console affecting reviews performance
Incident Report for AppFollow Status Page
Resolved
The issues are resolved.
Posted Mar 09, 2022 - 13:44 UTC
Monitoring
We have received the confirmation from the Google Play side that the issue with “Report a concern” issue has been fixed, and the dates are not getting affected any longer.

The fix for the issue with “Reply via Console” link is still in development.
Posted Feb 09, 2022 - 07:39 UTC
Identified
We’ve identified two changes to the Google Play Developer Console that are impacting reviews in AppFollow:

1. Changes to the “Report a Concern” flow: We have spotted unusual behavior of Google Play Reviews – when the “Report a concern” process is initiated either via AppFollow or directly from the Google Play Developer Console, the original date of the review gets updated and changes to the date of the report. We have confirmed that this issue stems from the Google Play Console and are working on communicating with the Google Play Development team to understand the cause and will keep you informed.

2. “Reply via Console” link: Due to changes in the Google Play URL format, the “Reply via console” button currently doesn’t work for Google Play reviews. We’re working on updating the format to ensure you’re redirected to the required review in the console.

We’ll share updates here as they become available.
Posted Feb 07, 2022 - 15:30 UTC
This incident affected: Google Play (Reply to Reviews).