Temporary Reviews Feed Unavailability

Incident Report for AppFollow Status Page

Postmortem

Summary
We experienced a brief global incident that caused the reviews feed to be unavailable for a small number of users. The issue lasted approximately 30 minutes and has been fully resolved.

Root Cause
A database connection limit was reached due to a MySQL configuration issue. The service user responsible for reply-to-review operations inherited a global connection limit, which was exceeded during a short load spike. This resulted in temporary errors. We are also investigating a possible accumulation of idle database connections that may have increased the likelihood of hitting this limit.

Resolution
The connection limit for the affected service user was increased and applied consistently across all databases. This immediately removed the bottleneck and restored normal operation.

Prevention Measures
To avoid similar incidents in the future, we are:

  • Explicitly configuring database connection limits per service and environment
  • Adding monitoring and alerts for per-user database connection usage
  • Reviewing database connection pooling and autoscaling behavior
  • Investigating and addressing potential connection leaks in backend services

We apologize for the disruption and appreciate your patience while we worked to resolve the issue.

Posted Jan 28, 2026 - 13:59 UTC

Resolved

We experienced a global incident lasting about 30 minutes, during which the reviews feed may have been unavailable for a small number of users. The issue has been resolved, and all services are operating normally.
Posted Jan 26, 2026 - 14:00 UTC