Star distribution do not appear on rating page

Incident Report for AppFollow Status Page

Resolved

Star distribution is back to normal now. Thanks for bearing with us.
Posted Nov 15, 2022 - 08:40 UTC

Investigating

We're aware of an issue in our Rating chart page and working to identify the cause and appropriate steps to remediate.
Posted Nov 14, 2022 - 18:42 UTC
This incident affected: Watch.