Duplicates of Google Play Reviews in AppFollow interface
Incident Report for AppFollow Status Page
Resolved
We're glad to announce that the issue with the duplicates has been resolved successfully for all our users.
Posted Aug 15, 2022 - 15:28 UTC
Update
Hello! We have a great update—we have finished the cleaning for all paid customers on the following servers: global2, global3 and global4. To learn what server your account is on, please scroll to the very bottom of any page in your AppFollow account, you'll find the name of your server next to "AppFollow" in between brackets.

We are continuing cleaning other servers and also normalizing functionality for all customers, paid and free.

Thank you and stay tuned.
Posted Aug 09, 2022 - 11:07 UTC
Update
We've been quiet for a while, but we've been working very hard.
Here's what was done to the moment:
We've changed the logic of the review collection to adapt to the most recent changes on the Google Play side.
The amount of data to process is nearly 2 Billion reviews and we already processed about 30% of it.
The process if very slow, and it is impossible to speed it up without affecting the platform performance.
We're incredibly grateful for your patience and will keep you updated.
Posted Jul 29, 2022 - 10:11 UTC
Update
We are still working on removing duplicates for reviews created before June 15th and preventing new duplicates from appearing.
The issue may affect analytical data (Agent Performance, Reviews & Replies chart, Semantic analysis) gathered before June 15th.
We're expecting the issue to be fixed by July 20th, please wait for the fix announcement to make sure that the data is accurate.
Posted Jul 06, 2022 - 10:17 UTC
Update
New reviews received after 15.06 shouldn't be duplicated, it is safe to reply to them. We are currently working on removing the duplicates created previously.
We'll keep you notified.
Posted Jun 17, 2022 - 09:09 UTC
Update
We are still working on the issue with duplicates. There might be some delays in collecting Google Play reviews today, on June 15th. Stay tuned!
Posted Jun 15, 2022 - 12:34 UTC
Monitoring
We have discovered that duplicated were caused by the changes made on the Google Play side in a way review ID is saved. We are currently adapting to these changes and continuously monitoring the situation. We have already deleted the majority of duplicates and applied the fix preventing duplicates from being sent to ticketing systems.
Posted Jun 13, 2022 - 13:14 UTC
Identified
Starting from June 7th we can see duplicates of Google Play reviews in AppFollow. We have found the root of the issue and removing all the duplicates now. We would recommend not to reply to these reviews until we have finished the cleaning because the reply might not get posted by the store. More updates to follow.
Posted Jun 07, 2022 - 13:13 UTC
This incident affected: Watch and Google Play (Reply to Reviews).