Issue with Android ASO metrics (caused by issues on Google Play side)
Incident Report for AppFollow Status Page
Resolved
This incident has been resolved.
Posted Oct 04, 2021 - 14:03 UTC
Update
We are continuing to investigate this issue.
Posted Oct 04, 2021 - 14:02 UTC
Investigating
ASO metrics (traffic, downloads, keywords distribution) are not being proceed on regular basis for Android apps. Google Play developer Support has confirmed that the issue is identified and is taken care of.
Some data maybe missing since September 18. We are waiting for the fix to be confirmed on Google Play side. We'll keep you posted.
Posted Sep 28, 2021 - 12:16 UTC
This incident affected: Google Play (ASO).