Reviews Delay

Incident Report for AppFollow Status Page

Resolved

Resolved
Posted May 02, 2025 - 12:00 UTC

Identified

We're currently experiencing performance degradation in review processing across all stores and connection types. As a result, some reviews may appear with delays in Watch. Our team is working to resolve the issue.
Posted May 01, 2025 - 08:06 UTC
This incident affected: App Store (Data Source Connection) and Google Play (Data Source Connection).