Reviews Summary Report Outage

Incident Report for AppFollow Status Page

Resolved

Resolved successfully.
Posted Oct 28, 2024 - 11:22 UTC

Investigating

The Reviews Summary Report feature is currently not operational. Our team is investigating the cause of the outage and working to restore functionality.
Posted Oct 25, 2024 - 13:35 UTC