"Reviews" & "Whatsnew" reports are not delivered
Incident Report for AppFollow Status Page
Resolved
"Reviews" & "Whatsnew" reports are back to normal now. Thank you for your patience.
Posted Nov 15, 2022 - 08:42 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 11, 2022 - 10:21 UTC
Investigating
The issue is under investigation
Posted Nov 11, 2022 - 08:28 UTC
This incident affected: Watch.