Web Application: Loading Issues
Incident Report for AppFollow Status Page
Resolved
This incident has been resolved.
Posted Jul 19, 2021 - 15:57 UTC
Identified
The issue impacting our website has been identified and we are working on our fix. We'll post updates as soon as they become available.
Posted Jul 19, 2021 - 15:45 UTC
Investigating
We've been alerted to a problem with the AppFollow web application not loading for some users. We're investigating the issue, and we'll post more information here as soon as we have it. Thank you for your patience as we investigate this!
Posted Jul 19, 2021 - 15:24 UTC
This incident affected: Watch.