Planned system update
Incident Report for AppFollow Status Page
Resolved
We have completed the transition to the new billing system.
Posted Jan 18, 2023 - 09:30 UTC
Monitoring
We will be transitioning to a new subscription system before the end of the year. The change is taking place to implement a more stable and scalable solution.
If you have any questions or if you experience changes in your account please let us know as soon as possible.
Posted Dec 02, 2022 - 14:02 UTC
This incident affected: Watch.