Degraded performance on some pages
Incident Report for AppFollow Status Page
Resolved
The incident is resolved.
Posted Nov 10, 2021 - 06:39 UTC
Identified
Some pages might have degraded performance now during next 3-4 hours. We are working on the fix already. We apologize for the inconvenience!
Posted Nov 09, 2021 - 13:57 UTC
This incident affected: Watch.