Issue with adding tags to reviews
Incident Report for AppFollow Status Page
Resolved
The tagging reviews issue has been resolved. You can tag reviews again.
Posted Mar 16, 2023 - 16:43 UTC
Identified
We're currently experiencing an issue with adding tags to reviews. Our team is aware of the problem and is actively working on a fix. We apologize for any inconvenience this may cause.

We expect to have the issue resolved within the next several hours.
Posted Mar 16, 2023 - 14:07 UTC
This incident affected: Watch.