Website Loading Issues
Incident Report for AppFollow Status Page
Resolved
All systems are operating as expected.
Posted Jul 27, 2021 - 12:31 UTC
Identified
Some clients may currently experience intermittent loading issues in some areas of the website. We're restarting our services and a fix is already on the way; we'll keep you posted. Thank you for your patience!
Posted Jul 27, 2021 - 11:34 UTC
Investigating
Some clients may currently experience intermittent loading issues in some areas of the website. We're restarting our services and a fix is already on the way; we'll keep you posted. Thank you for your patience!
Posted Jul 27, 2021 - 11:34 UTC
This incident affected: Watch.