Daily Email Report Delays
Incident Report for AppFollow Status Page
Resolved
This incident has been resolved.
Posted Sep 10, 2021 - 17:58 UTC
Identified
We have identified an issue where today's daily email reports were not delivered. A fix is already on the way – your email reports will be with you shortly. Thank you for your patience!
Posted Sep 10, 2021 - 08:36 UTC
This incident affected: Integrations (Email).